Project

General

Profile

Bug #1534

Crash when doing stuff with audio (no midi)

Added by Anonymous about 2 months ago. Updated 29 days ago.

Status:
Closed
Priority:
Immediate
Category:
User Interface
Target version:
Start date:
05/16/2020
Due date:
% Done:

0%

Estimated time:

Description

Steps to reproduce

Write a list of steps to reproduce the bug

What happens?

I was moving the audio track around, to see what I could do with it. I don't really know why the crash happened.

What is expected?

Version

Zrythm 0.8.459
built with gcc 9.3.0
+carla
+ffmpeg
+jack
+rtmidi
+rtaudio
+sdl2

Other info

Ubuntu 20.04 with ubuntu studio packages.

Nvidia 1080 with proprietary driver (v 440)

AMD ryzen 3 processor

Backtrace

Error: Segmentation fault - Backtrace:
/usr/bin/zrythm(+0x56ce6) [0x55e6ed22ace6]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x153c0) [0x7fc7f23683c0]
/usr/bin/zrythm(+0xd677c) [0x55e6ed2aa77c]
/lib/x86_64-linux-gnu/libgtk-3.so.0(+0x3eb80e) [0x7fc7f5ea380e]
/lib/x86_64-linux-gnu/libgobject-2.0.so.0(+0x14a56) [0x7fc7f55d8a56]
/lib/x86_64-linux-gnu/libgobject-2.0.so.0(g_signal_emit_valist+0x1038) [0x7fc7f55f7b28]
/lib/x86_64-linux-gnu/libgobject-2.0.so.0(g_signal_emit+0x93) [0x7fc7f55f80d3]
/lib/x86_64-linux-gnu/libgobject-2.0.so.0(g_cclosure_marshal_VOID__BOXEDv+0xa6) [0x7fc7f55dbc56]
/lib/x86_64-linux-gnu/libgobject-2.0.so.0(+0x14a56) [0x7fc7f55d8a56]
/lib/x86_64-linux-gnu/libgobject-2.0.so.0(g_signal_emit_valist+0x1038) [0x7fc7f55f7b28]
/lib/x86_64-linux-gnu/libgobject-2.0.so.0(g_signal_emit+0x93) [0x7fc7f55f80d3]
/lib/x86_64-linux-gnu/libgtk-3.so.0(+0x201fa2) [0x7fc7f5cb9fa2]
/lib/x86_64-linux-gnu/libgtk-3.so.0(+0x2035eb) [0x7fc7f5cbb5eb]
/lib/x86_64-linux-gnu/libgtk-3.so.0(+0x2065d6) [0x7fc7f5cbe5d6]
/lib/x86_64-linux-gnu/libgtk-3.so.0(gtk_event_controller_handle_event+0x70) [0x7fc7f5c85bb0]
/lib/x86_64-linux-gnu/libgtk-3.so.0(+0x3900fd) [0x7fc7f5e480fd]
/lib/x86_64-linux-gnu/libgtk-3.so.0(+0x394760) [0x7fc7f5e4c760]
/lib/x86_64-linux-gnu/libgtk-3.so.0(+0x24d043) [0x7fc7f5d05043]
/lib/x86_64-linux-gnu/libgtk-3.so.0(gtk_main_do_event+0x6c0) [0x7fc7f5d07190]
/lib/x86_64-linux-gnu/libgdk-3.so.0(+0x3cf79) [0x7fc7f59eff79]
/lib/x86_64-linux-gnu/libgdk-3.so.0(+0x70106) [0x7fc7f5a23106]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x27d) [0x7fc7f54ecfbd]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x52240) [0x7fc7f54ed240]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x33) [0x7fc7f54ed2e3]
/lib/x86_64-linux-gnu/libgio-2.0.so.0(g_application_run+0x205) [0x7fc7f5706fd5]
/usr/bin/zrythm(main+0x503) [0x55e6ed22a9d3]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf3) [0x7fc7f21880b3]
/usr/bin/zrythm(_start+0x2e) [0x55e6ed22ab2e]

History

#1 Updated by Alexandros Theodotou about 2 months ago

  • Category set to User Interface
  • Priority changed from Normal to High
  • Target version set to 0.9 beta

#2 Updated by Alexandros Theodotou about 1 month ago

  • Assignee set to Alexandros Theodotou
  • Priority changed from High to Immediate
  1. create instrument track
  2. create region
  3. bounce
  4. move audio track

undoing after this also seems to be broken

#3 Updated by Alexandros Theodotou 29 days ago

  • Status changed from New to Closed

fixed with 5255ab5d4e57a37e7f35850bf5362e2d08986ae4

Also available in: Atom PDF