Project

General

Profile

Bug #1546

Crash on Draw MIDI Region

Added by Anonymous 16 days ago. Updated 8 days ago.

Status:
Closed
Priority:
Normal
Category:
Actions
Target version:
Start date:
05/20/2020
Due date:
% Done:

0%

Estimated time:

Description

Steps to reproduce

Write a list of steps to reproduce the bug

What happens?

Please tell us what happened

Created MIDI track by dragging drum machine over, and then going into "Edit" mode, and then attempting to draw a MIDI region. After the MIDI region was drawn, the program then crashed

What is expected?

To draw a MIDI region and start filling the container

What is expected to happen?

To draw a MIDI region and start filling the container

Version

Zrythm 0.8.397
built with gcc 6.3.0
+carla
+jack
+rtmidi
+rtaudio
+sdl2

Other info

Context, distro, etc.

Backtrace

Error: Segmentation fault - Backtrace:
/usr/bin/zrythm(+0x50dc9) [0x5598f8e73dc9]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x110e0) [0x7fe060dd80e0]
/usr/bin/zrythm(arranger_object_find+0x6c) [0x5598f8e9e70c]
/usr/bin/zrythm(+0x569e1) [0x5598f8e799e1]
/usr/bin/zrythm(+0x56b6c) [0x5598f8e79b6c]
/usr/bin/zrythm(undo_manager_perform+0x14) [0x5598f8e7cc24]
/usr/bin/zrythm(+0xfcc97) [0x5598f8f1fc97]
/usr/lib/x86_64-linux-gnu/libffi.so.6(ffi_call_unix64+0x4c) [0x7fe05bb42038]
/usr/lib/x86_64-linux-gnu/libffi.so.6(ffi_call+0x32a) [0x7fe05bb41a9a]
/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0(g_cclosure_marshal_generic_va+0x35a) [0x7fe064addc8a]
/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0(+0x101a4) [0x7fe064add1a4]
/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0(g_signal_emit_valist+0xb2d) [0x7fe064af78cd]
/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0(g_signal_emit+0x8f) [0x7fe064af7fbf]
/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0(g_cclosure_marshal_VOID__BOXEDv+0x87) [0x7fe064adfd27]
/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0(+0x101a4) [0x7fe064add1a4]
/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0(g_signal_emit_valist+0xb2d) [0x7fe064af78cd]
/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0(g_signal_emit+0x8f) [0x7fe064af7fbf]
/usr/lib/x86_64-linux-gnu/libgtk-3.so.0(+0x1e3e3e) [0x7fe065f21e3e]
/usr/lib/x86_64-linux-gnu/libgtk-3.so.0(+0x1e546b) [0x7fe065f2346b]
/usr/lib/x86_64-linux-gnu/libgtk-3.so.0(+0x1e80ed) [0x7fe065f260ed]
/usr/lib/x86_64-linux-gnu/libgtk-3.so.0(gtk_event_controller_handle_event+0x9e) [0x7fe065ef355e]
/usr/lib/x86_64-linux-gnu/libgtk-3.so.0(+0x37a2db) [0x7fe0660b82db]
/usr/lib/x86_64-linux-gnu/libgtk-3.so.0(+0x37e792) [0x7fe0660bc792]
/usr/lib/x86_64-linux-gnu/libgtk-3.so.0(+0x22cb43) [0x7fe065f6ab43]
/usr/lib/x86_64-linux-gnu/libgtk-3.so.0(gtk_main_do_event+0x623) [0x7fe065f6ca73]
/usr/lib/x86_64-linux-gnu/libgdk-3.so.0(+0x36e15) [0x7fe065a7de15]
/usr/lib/x86_64-linux-gnu/libgdk-3.so.0(+0x67ea2) [0x7fe065aaeea2]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x2a7) [0x7fe0648037f7]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x4aa60) [0x7fe064803a60]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x2c) [0x7fe064803b0c]
/usr/lib/x86_64-linux-gnu/libgio-2.0.so.0(g_application_run+0x20d) [0x7fe064dbf72d]
/usr/bin/zrythm(main+0x32d) [0x5598f8e73b6d]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf1) [0x7fe060a482e1]
/usr/bin/zrythm(_start+0x2a) [0x5598f8e73c7a]

Log

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkBox 0x5598fa046170 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkScrolledWindow 0x5598f9fcb0a0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?
** Message: drag_update

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkBox 0x5598fa00df40 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkBox 0x5598fa046170 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkScrolledWindow 0x5598f9fcb0a0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?
** Message: drag_update

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkBox 0x5598fa00df40 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkBox 0x5598fa046170 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkScrolledWindow 0x5598f9fcb0a0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?
** Message: drag_update

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkBox 0x5598fa00df40 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkBox 0x5598fa046170 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkScrolledWindow 0x5598f9fcb0a0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?
** Message: drag_update

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkBox 0x5598fa00df40 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkBox 0x5598fa046170 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkScrolledWindow 0x5598f9fcb0a0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?
** Message: drag_update

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkBox 0x5598fa00df40 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkBox 0x5598fa046170 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkScrolledWindow 0x5598f9fcb0a0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?
** Message: drag_update

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkBox 0x5598fa00df40 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkBox 0x5598fa046170 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkScrolledWindow 0x5598f9fcb0a0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?
** Message: drag_update

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkBox 0x5598fa00df40 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkBox 0x5598fa046170 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(zrythm:8527): Gtk-WARNING **: Allocating size to GtkScrolledWindow 0x5598f9fcb0a0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?
** Message: toggling
** Message: FOCUSED
** Message: objects hit 0
** Message: -----num lanes 1, lanes size 2
** Message: [DOING ACTION]: CREATE_ARRANGER_SELECTIONS

** (zrythm:8527): CRITICAL **: file ../../src/audio/region.c: line 478 (region_find): should not be reached

thank you

History

#1 Updated by Alexandros Theodotou 12 days ago

  • Category set to Actions
  • Status changed from New to Resolved
  • Target version set to 0.9 beta

cannot reproduce. I believe this is already fixed in the newer versions

#2 Updated by Alexandros Theodotou 8 days ago

  • Status changed from Resolved to Closed
  • Assignee set to Alexandros Theodotou

Also available in: Atom PDF